iPhone 4 simulator with XCode 8

user7343623 Source

I am trying to use my iPhone 4 with Xcode 8, and am running into this error:

Could not locate device support files. This iPhone 4 is running iOS 7.1.2 (11D257), which may not be supported by this version of Xcode.

There are a number of existing StackOverflow questions related to this issue (see links below). The general accepted answer is to:

Copy DeviceSupport folder for iOS 7.1 from Xcode 7 to the new one. It's located in: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/7.1

I'm having trouble actually following this advice. I've located the /DeviceSupport/ folder in Xcode, which has a number of folders inside it for versions 8.0 - 10.2. Should I create a new folder in it called 7.1/, and copy the contents of 10.2/ into the folder? Should I install an older version of Xcode (version 7), and copy the folder in that version of Xcode into the newer one? Thanks for your help.

Related questions:

Any way to install app to iPhone 4 with Xcode 8 beta?

The iPhone 4 and iPhone 4s simulators disappeared after upgrading to Xcode 8. How do I get them back?

iosiphonexcode

Answers

comments powered by Disqus