How to deal with the error libXdamage.so.1: cannot open shared object file on Centos VM?

Alex Source

Running a Java program got the exception:

Caused by:
    org.openqa.selenium.firefox.NotConnectedException: Unable to connect to host 127.0.0.1 on port 7055 after 45000 ms. 
Firefox console output:\nXPCOMGlueLoad error for file 
/home/anarinsky/.alternator/browsers/firefox/libxul.so:
libXdamage.so.1:
cannot open shared object file: No such file or directory
Couldn't load XPCOM.\n

Assumed that this exception is due to the absence of installed libXdamage.so.1, so I downloaded rpm libXdamage-1.1.4-12.fc28.armv7hl.rpm, but installation:

rpm -ivh libXdamage-1.1.4-12.fc28.armv7hl.rpm

resulted in the following error:

warning: libXdamage-1.1.4-12.fc28.armv7hl.rpm: Header V3 RSA/SHA256

Signature, key ID 429476b4: NOKEY error: Failed dependencies:

ld-linux-armhf.so.3 is needed by libXdamage-1.1.4-12.fc28.armv7hl
ld-linux-armhf.so.3(GLIBC_2.4) is needed by libXdamage-1.1.4-12.fc28.armv7hl
libX11.so.6 is needed by libXdamage-1.1.4-12.fc28.armv7hl
libXfixes.so.3 is needed by libXdamage-1.1.4-12.fc28.armv7hl
libc.so.6 is needed by libXdamage-1.1.4-12.fc28.armv7hl
libc.so.6(GLIBC_2.4) is needed by libXdamage-1.1.4-12.fc28.armv7hl
libgcc_s.so.1 is needed by libXdamage-1.1.4-12.fc28.armv7hl
libgcc_s.so.1(GCC_3.5) is needed by libXdamage-1.1.4-12.fc28.armv7hl

Started from installing libX11 but got the failed dependencies again

Is it possible to install all packages at once? Or maybe to download a Centos VM that already contains all packages? If the 2nd way is possible please provide the URL for downloading.

linuxcentosvirtual-machinerpm

Answers

answered 1 week ago Knud Larsen #1

Find the package providing libXdamage.so.1: # yum provides */libXdamage.so.1

Install libXdamage :

# yum install libXdamage

Anyway, a Fedora 28 pagkage won't do for CentOS http://mirror.centos.org/centos/

( And it doesn't seem like you have an OS for "armv7hl" processor. Hence the dependencies.)

comments powered by Disqus