R , error due to parallelisation

Bitsy Source

I am using a particular R package called wTO (https://cran.r-project.org/web/packages/wTO/index.html)

It is basically used to construct correlation networks

The main command I have to execute is :

>x= wTO.Complete(k = 32, n = 100, Data, Overlap, method = "p", method_resampling = "Bootstrap", pvalmethod = "BH", savecor = F, expected.diff = 0.2, lag = NULL, normalize = F, plot = T)

Here, I have used k=32, computer threads to be used in the calculations on a CENTOS server. To parallelise, the developer had used the R package "parallel"

My first network was easily constructed in 45 mins. But I started getting errors from then on, although the matrix size was comparable (20k nodes). Reducing k still throws the same error.

I am getting the error: Error in unserialize(node$con) : error reading from connection

I read in some forums that it is due to parallel threads. Kindly help.

sessionInfo()
R version 3.4.1 (2017-06-30)`
Platform: x86_64-redhat-linux-gnu (64-bit)`
Running under: CentOS release 6.8 (Final)`
Matrix products: default`
BLAS: /usr/lib64/R/lib/libRblas.so
LAPACK: /usr/lib64/R/lib/libRlapack.so

locale:
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8
 [5] LC_MONETARY=en_US.UTF-8    LC_MESSAGES=en_US.UTF-8
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C
 [9] LC_ADDRESS=C               LC_TELEPHONE=C
[11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

other attached packages:
[1] wTO_1.6

loaded via a namespace (and not attached):
[1] Rcpp_0.12.12      visNetwork_2.0.3  digest_0.6.12     plyr_1.8.4
[5] jsonlite_1.5      magrittr_1.5      stringi_1.1.5     som_0.3-5.1
[9] reshape2_1.4.2    data.table_1.10.4 tools_3.4.1       stringr_1.2.0
[13] htmlwidgets_0.9   igraph_1.2.1      parallel_3.4.1    compiler_3.4.1
[17] pkgconfig_2.0.1   htmltools_0.3.6
r

Answers

comments powered by Disqus