Pandas won't import (Python3.5) (Raspberry Pi 3)

smashed__ Source

I have installed pandas, numpy, and matplotlib using pip3. Importing numpy and matplotlib is successful, but importing pandas results in the following error.

RuntimeError: module compiled against API version 0xc but this version of numpy is 0xa
RuntimeError: module compiled against API version 0xc but this version of numpy is 0xa

If I uninstall matplotlib and import only pandas and numpy, they successfully import.

I have installed these packages in python2.7 and they are all able to import.

I am running the most recent version of Raspbian.

pythonpython-3.xpython-2.7pandasmatplotlib

Answers

answered 4 months ago smashed__ #1

I ended up uninstalling matplotlib and pandas using

sudo pip3 uninstall <module>

Then I installed pandas using:

sudo pip3 install -U pandas

and then installed matplotlib again using:

sudo pip3 install matplotlib

comments powered by Disqus